vlr-pers-p (AutoLISP/ActiveX)

Determines whether a reactor is persistent

Supported Platforms: Windows only

Signature

(vlr-pers-p reactor)
reactor

Type: VLR object

An object.

Return Values

Type: VLR object or nil

The specified reactor object, if it is persistent; nil, if the reactor is transient.

Examples

Make a reactor persistent:

(vlr-pers circleReactor)
#<VLR-Object-Reactor>

Verify that a reactor is persistent:

(vlr-pers-p circleReactor)
#<VLR-Object-Reactor>

Change the persistent reactor to transient:

(vlr-pers-release circleReactor)
#<VLR-Object-Reactor>

Verify that the reactor is no longer persistent:

(vlr-pers-p circleReactor)
nil