Variables can be stored and retrieved across multiple open drawings using the blackboard namespace.
Returns:
0
The *example* variable is set to 0 in the blackboard namespace.
Returns:
0
Returns:
nil
The *example* variable returns nil because it has not been set in the document namespace.
Returns:
-1
The *example* variable is set to -1 in the document namespace.
Returns:
0
The blackboard variable named *example* is still set to the value assigned in Step 1; setting the document variable of the same name in Step 4 had no effect on the variable in the blackboard.
You can also the vl-doc-set and vl-doc-ref functions to set and retrieve document namespace variables from a separate-namespace VLX, and vl-propagate to set the value of a variable in all open document namespaces.