Namespace Communication Functions Reference (AutoLISP)

The namespace communication functions consist of blackboard addressing and multi-document-loading functions.

Namespace communication functions

Function

Description

(vl-bb-ref 'variable)

Returns the value of a variable from the blackboard namespace

(vl-bb-set 'variable value)

Sets the value of a variable in the blackboard namespace

(vl-load-all "filename")

Loads a file into all open AutoCAD documents, and into any document subsequently opened during the current AutoCAD session

(vl-propagate 'variable)

Copies the value of a variable into all open AutoCAD documents, and into any document subsequently opened during the current AutoCAD session