getreal (AutoLISP)

Pauses for user input of a real number, and returns that real number

Supported Platforms: Windows and Mac OS

Signature

(getreal [msg])
msg

Type: String

Message to be displayed to prompt the user.

Return Values

Type: Real or nil

The number entered by the user and expressed as a real.

Remarks

The user cannot enter another AutoLISP expression as the response to a getreal request.

Examples

(setq val (getreal)) 
(setq val (getreal "Scale factor: "))