Constructs a reactor object that notifies when an object is added to, modified in, or erased from a drawing database
Supported Platforms: Windows only
(vlr-acdb-reactor data callbacks)
Type: Integer, Real, String, List, VLA-object, Safearray, Variant, T, or nil
Any AutoLISP data to be associated with a reactor object; otherwise nil, if no data.
Type: List
A list of pairs of the following form:
(event-name . callback_function)
event-name is one of the following Database reactor events:
Database reactor events |
|
---|---|
Name |
Event |
:vlr-objectAppended |
An object has been appended to the drawing database. |
:vlr-objectUnAppended |
An object has been detached from the drawing database, e.g., by using UNDO. |
:vlr-objectReAppended |
A detached object has been restored in the drawing database, e.g., by using REDO. |
:vlr-objectOpenedForModify |
An object is about to be changed. |
:vlr-objectModified |
An object has been changed. |
:vlr-objectErased |
An object has been flagged as being erased. |
:vlr-objectUnErased |
An object's erased-flag has been removed. |
callback_function is a symbol representing a function to be called when the event fires. Each callback function accepts two arguments:
reactor_object -- The VLR object that called the callback function
obj -- The database object associated with the event
Type: VLR object
The reactor_object argument from the callback_function.
The vlr-acdb-reactor function constructs a database reactor object.
N/A