vlr-deepclone-reactor (AutoLISP/ActiveX)

Constructs an editor reactor object that notifies of a deep clone event

Supported Platforms: Windows only

Signature

(vlr-deepclone-reactor data callbacks)
data

Type: Integer, Real, String, List, VLA-object, Safearray, Variant, T, or nil

Any AutoLISP data to be associated with the reactor object; otherwise nil if no data.

callbacks

Type: List

A list of pairs of the following form:

(event-name . callback_function)

  • event-name is one of the following DeepClone reactor events:

    DeepClone reactor events

    Event name

    Description

    :vlr-beginDeepClone

    A deep clone operation is beginning.

    :vlr-beginDeepCloneXlation

    A deep clone operation has two stages. First, each object and any owned objects are cloned. Second, any object ID references are translated to their cloned IDs. This callback occurs between these two stages.

    :vlr-abortDeepClone

    A deep clone operation is aborting.

    :vlr-endDeepClone

    A deep clone operation is ending.

  • callback_function is a symbol representing a function to be called when the event fires. Each callback function accepts two arguments:

    reactor_object -- The VLR object that called the callback function.

    list -- A list of extra data elements associated with the particular event. The contents of this list for particular events are shown in the “DeepClone reactor callback data” table.

    DeepClone reactor callback data

    Name

    List length

    Parameters

    :vlr-beginDeepClone

    :vlr-abortDeepClone

    :vlr-endDeepClone

    0

    :vlr-beginDeepCloneXlation

    1

    An integer containing the return error status; if this value indicates an error, the deep clone operation is terminated

Return Values

Type: VLR object

The reactor_object argument from the callback_function.

Examples

N/A