vl-file-size (AutoLISP)

Determines the size of a file, in bytes

Supported Platforms: Windows and Mac OS

Signature

(vl-file-size filename)
filename

Type: String

Naming the file to be sized. If you do not specify a full path name, vl-file-size searches the AutoCAD default drawing directory for the file.

Return Values

Type: Integer

If successful, vl-file-size returns an integer showing the size of filename. If the file is not readable, vl-file-size returns nil. If filename is a directory or an empty file, vl-file-size returns 0.

Examples

Windows
(vl-file-size "c:/autoexec.bat")
1417

(vl-file-size "c:/")
0

In the preceding example, vl-file-size returned 0 because c:/ names a directory.

Mac OS
(vl-file-size "/output.txt")
568

(vl-file-size "/")
0

In the preceding example, vl-file-size returned 0 because / names the <root> of the drive and not a file.