vl-filename-directory (AutoLISP)

Returns the directory path of a file, after stripping out the name and extension

Supported Platforms: Windows and Mac OS

Signature

(vl-filename-directory filename)
filename

Type: String

Complete file name, including the path. The vl-filename-directory function does not check to see if the specified file exists. Slashes (/) and backslashes (\) are accepted as directory delimiters.

Return Values

Type: String

A textual value containing the directory portion of filename, in uppercase.

Examples

Windows
(vl-filename-directory "c:\\acadwin\\template.txt")
"C:\\ACADWIN"

(vl-filename-directory "template.txt")
""
Mac OS
(vl-filename-directory "/myutilities/support/template.txt")
"/myutilities/support"

(vl-filename-directory "template.txt")
""