vl-exit-with-value (AutoLISP)

Returns a value to the function that invoked the *error* handler from another namespace

Supported Platforms: Windows and Mac OS

Signature

(vl-exit-with-value value)
value

Type: Integer, Real, String, List, File, Ename (entity name), T, or nil

Any value.

Return Values

Type: Integer, Real, String, List, File, Ename (entity name), T, or nil

value provided to the function.

Remarks

An *error* handler can use the vl-exit-with-value function to return a value to the program that called the function.

Examples

The following example uses vl-exit-with-value to return the integer value 3 to the function that invoked the VLX:

(defun *error* (msg)
  ... ; processing in VLX-T namespace/execution context
  (vl-exit-with-value  3))