The VLX namespace functions listed below apply to separate-namespace VLX applications. These functions allow separate-namespace VLX functions to be accessible from a document namespace, enable the retrieval and updating of variables in the associated document namespace, and provide error-handling routines for separate-namespace VLX functions.
VLX namespace functions |
|
---|---|
Function |
Description |
(vl-arx-import [ function | application]) |
Imports ADS-DEFUN functions into a separate-namespace VLX |
(vl-doc-export 'function) |
Makes a function loaded in a VLX namespace available to the current document |
(vl-doc-import ['function | application]) |
Imports a function that was previously exported from another separate-namespace VLX |
(vl-doc-ref symbol) |
Retrieves the value of a variable from the namespace of the associated document |
(vl-doc-set symbol value) |
Sets the value of a variable in the associated document's namespace |
(vl-exit-with-error "msg") |
Passes control from a VLX error handler to the *error* function of the associated document namespace |
(vl-exit-with-value value) |
Returns a value to the document namespace from which the VLX was invoked |
(vl-list-exported-functions [“appname”]) |
Lists all functions exported by the specified application, or all exported functions if no application is specified |
(vl-list-loaded-vlx) |
Returns a list of all separate-namespace VLX files associated with the current document |
(vl-unload-vlx "appname") |
Unloads a VLX that is loaded in its own namespace (a separate-namespace VLX) |
(vl-vlx-loaded-p "appname") |
Determines whether a VLX is loaded in its own namespace |