vlax-for (AutoLISP/ActiveX)

Iterates through a collection of objects, evaluating each expression

Supported Platforms: Windows only

Signature

(vlax-for symbol collection [expression1 [expression2 ...]])
symbol

Type: VLA-object

A symbol to be assigned to each VLA-object in a collection.

collection

Type: VLA-object

A VLA-object representing a collection object.

expression1, expression2...

Type: List, Subroutine, or Symbol

The expressions to be evaluated.

Return Values

Type: Integer, Real, String, List, VLA-object, Variant, Safearray, T, or nil

The value of the last expression evaluated for the last object in the collection.

Examples

The following code issues vlax-dump-object on every drawing object in the model space:

(vl-load-com)                        ; load ActiveX support
(vlax-for for-item 
   (vla-get-modelspace
        (vla-get-activedocument (vlax-get-acad-object))
   )
  (vlax-dump-object for-item)        ; list object properties
)