Lists an object's properties, and optionally, the methods that apply to the object
Supported Platforms: Windows only
(vlax-dump-object obj [flag])
Type: VLA-object
An object.
Type: T or nil
If specified and not nil, vlax-dump-object also lists all methods that apply to obj.
Type: T or error
T, if successful. If an invalid object name is supplied, vlax-dump-object displays an error message.
(setq aa (vlax-get-acad-object)) #<VLA-OBJECT IAcadApplication 00b3b91c> (vlax-dump-object aa) ; IAcadApplication: AutoCAD Application Interface ; Property values: ; ActiveDocument (RO) = #<VLA-OBJECT IAcadDocument 01b52fac> ; Application (RO) = #<VLA-OBJECT IAcadApplication 00b3b91c> ; Caption (RO) = "AutoCAD - [Drawing.dwg]" . . . T
List an object's properties and the methods that apply to the object:
(vlax-dump-object aa T) ; IAcadApplication: AutoCAD Application Interface ; Property values: ; ActiveDocument (RO) = #<VLA-OBJECT IAcadDocument 01b52fac> ; Application (RO) = #<VLA-OBJECT IAcadApplication 00b3b91c> ; Caption (RO) = "AutoCAD - [Drawing.dwg]" . . . ; Methods supported: ; EndUndoMark () ; Eval (1) ; GetInterfaceObject (1) ; ListAds () ; ListArx () . . . T