vlax-ldata-list (AutoLISP/ActiveX)

Lists AutoLISP data in a drawing dictionary

Supported Platforms: Windows only

Signature

(vlax-ldata-list dict [private])
dict

Type: VLA-object or String

An object, an AutoCAD drawing entity object, or a string naming a global dictionary.

private

Type: T or nil

If vlax-ldata-list is called from a separate-namespace VLX and a non-nil value is specified for private, vlax-ldata-list retrieves only private data stored by the same VLX.

Return Values

Type: List

An associative list consisting of pairs (key . value).

Examples

Use vlax-ldata-put to store LISP data in a dictionary:

(vlax-ldata-put "dict" "cay" "Mumbo Jumbo ")
"Mumbo Jumbo"

(vlax-ldata-put "dict" "say" "Floobar ")
"Floobar"

Use vlax-ldata-list to display the LISP data stored in “dict”:

 (vlax-ldata-list "dict")
(("say" . "Floobar") ("cay" . "Mumbo Jumbo"))