vlax-ldata-put (AutoLISP/ActiveX)

Stores LISP data in a drawing dictionary or an object

Supported Platforms: Windows only

Signature

(vlax-ldata-put dict key data [private])
dict

Type: VLA-object or String

A object, an AutoCAD drawing entity object, or a string naming a global dictionary.

key

Type: String

Dictionary key.

data

Type: Integer, Real, String, List, Ename (entity name), VLA-object, Variant, Safearray, T, or nil

LISP data to be stored in the dictionary.

private

Type: T or nil

If vlax-ldata-put is called from a separate-namespace VLX and a non-nil value is specified for private, vlax-ldata-put marks the data as retrievable only by the same VLX.

Return Values

Type: Integer, Real, String, List, Ename (entity name), VLA-object, Variant, Safearray, T, or nil

The value of data.

Examples

(vlax-ldata-put "dict" "key" '(1))
(1)

(vlax-ldata-put "dict" "cay" "Gumbo jumbo")
"Gumbo jumbo"