vlr-toolbar-reactor (AutoLISP/ActiveX)

Constructs an editor reactor object that notifies of a change to the bitmaps in a toolbar

Supported Platforms: Windows only

Signature

(vlr-toolbar-reactor data callbacks)
data

Type: Integer, Real, String, List, VLA-object, Safearray, Variant, T, or nil

Any AutoLISP data to be associated with the reactor object; otherwise nil if no data.

callbacks

Type: List

A list of pairs of the following form:

(event-name . callback_function)

  • event-name is one of the following Toolbar reactor events:

    Toolbar reactor events

    Event name

    Description

    :vlr-toolbarBitmapSizeWillChange

    The size of the AutoCAD toolbar icons is about to change.

    :vlr-toolbarBitmapSizeChanged

    The size of the AutoCAD toolbar icons has changed.

  • callback_function is a symbol representing a function to be called when the event fires. Each callback function accepts two arguments:

    reactor_object -- The VLR object that called the callback function.

    list -- A list of extra data elements associated with the particular event. The contents of this list for particular events are shown in the “Toolbar reactor callback data” table.

    Toolbar reactor callback data

    Name

    List length

    Parameters

    :vlr-toolbarBitmapSizeWillChange

    :vlr-toolbarBitmapSizeChanged

    1

    T, if the toolbar is being set to large bitmaps; nil if the toolbar is being set to small bitmaps.

Return Values

Type: VLR object

The reactor_object argument from the callback_function.

Examples

N/A