vlax-put-property (AutoLISP/ActiveX)

Sets the property of an ActiveX object

Supported Platforms: Windows only

Signature

(vlax-put-property obj property arg)
obj

Type: VLA-object

An object.

property

Type: Symbol or String

Name of the property to be set.

arg

Type: Integer, Real, String, VLA-object, Safearray, Variant, T, or nil

The value to be set.

Return Values

Type: nil or error

nil, if successful; otherwise, an error occurs.

Remarks

This function was formerly known as vlax-put.

Examples

Color an object red:

(vlax-put-property vlaobj 'Color 1)
nil