vlr-data-set (AutoLISP/ActiveX)

Overwrites application-specific data associated with a reactor

Supported Platforms: Windows only

Signature

(vlr-data-set obj data)
obj

Type: VLR object

A object representing the reactor object whose data is to be overwritten.

data

Type: Integer, Real, String, List, VLA-object, Safearray, Variant, T, or nil

Any AutoLISP data.

Return Values

Type: Integer, Real, String, List, VLA-object, Safearray, Variant, T, or nil

The data argument.

Remarks

Note: The vlr-data-set function should be used with care to avoid creation of circular structures.

Examples

Return the application-specific data value attached to a reactor:

(vlr-data circleReactor)
"Circle Reactor"

Replace the text string used to identify the reactor:

(vlr-data-set circleReactor "Circle Area Reactor")
"Circle Area Reactor"

Verify the change:

(vlr-data circleReactor)
"Circle Area Reactor"