vlr-dxf-reactor (AutoLISP/ActiveX)

Constructs an editor reactor object that notifies of an event related to reading or writing a DXF file

Supported Platforms: Windows only

Signature

(vlr-dxf-reactor data callbacks)
data

Type: Integer, Real, String, List, VLA-object, Safearray, Variant, T, or nil

Any AutoLISP data to be associated with the reactor object; otherwise nil if no data.

callbacks

Type: List

A list of pairs of the following form:

(event-name . callback_function)

  • event-name is one of the following DXF reactor events:

    DXF reactor events

    Event name

    Description

    :vlr-beginDxfIn

    The contents of a DXF file are to be appended to the drawing database.

    :vlr-abortDxfIn

    The DXF import was not successful.

    :vlr-dxfInComplete

    The DXF import was successful.

    :vlr-beginDxfOut

    AutoCAD is about to export the drawing database into a DXF file.

    :vlr-abortDxfOut

    The DXF export operation failed.

    :vlr-dxfOutComplete

    The DXF export operation was successful.

  • callback_function is a symbol representing a function to be called when the event fires. Each callback function accepts two arguments:

    reactor_object -- The VLR object that called the callback function.

    list -- A list of extra data elements associated with the particular event. The contents of this list for particular events are shown in the “DXF reactor callback data” table.

    DXF reactor callback data

    Name

    List length

    :vlr-beginDxfIn

    :vlr-abortDxfIn

    :vlr-dxfInComplete,

    :vlr-beginDxfOut

    :vlr-abortDxfOut

    :vlr-dxfOutComplete

    0

Return Values

Type: VLR object

The reactor_object argument from the callback_function.

Examples

N/A