min (AutoLISP)

Returns the smallest of the numbers given

Supported Platforms: Windows and Mac OS

Signature

(min [number number ...])
number

Type: Integer or Real

A numeric value.

Return Values

Type: Integer or Real

A numeric value. If any number argument is a real, a real is returned; otherwise, an integer is returned. If no argument is supplied, min returns 0.

Examples

(min 683 -10.0)
-10.0

(min 73 2 48 5)
2

(min 73.0 2 48 5)
2.0

(min 2 4 6.7)
2.0