dictrename (AutoLISP)

Renames a dictionary entry

Supported Platforms: Windows and Mac OS

Signature

(dictrename ename oldsym newsym)
ename

Type: Ename (entity name)

Name of the dictionary being modified.

oldsym

Type: String

Original key name of the entry.

newsym

Type: String

New key name of the entry.

Return Values

Type: String or nil

The newsym value, if the rename is successful. If the oldname is not present in the dictionary, or if ename or newname is invalid, or if newname is already present in the dictionary, then dictrename returns nil.

Examples

The following example renames the dictionary created in the dictadd sample:

(dictrename (namedobjdict) "my_way_cool_dictionary" "An even cooler dictionary")
"An even cooler dictionary"