FloatingRows Property (ActiveX)

Specifies the number of rows for a floating toolbar.

Supported platforms: Windows only

Signature

VBA:

object.FloatingRows
object

Type: Toolbar

The object this property applies to.

Property Value

Read-only: No

Type: Integer

The number of rows for a floating toolbar.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_FloatingRows()
    ' This example creates a new toolbar called "TestToolbar" and inserts three
    ' buttons into it. The toolbar is then displayed as a floating
    ' toolbar with 1 and then 3 rows.
    ' To remove the toolbar after execution of this macro, use the Customize Menu
    ' option from the Tools menu.
    
    Dim currMenuGroup As acadMenuGroup
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)
    
    ' Create the new toolbar
    Dim newToolBar As AcadToolbar
    Set newToolBar = currMenuGroup.Toolbars.Add("TestToolbar")
    
    ' Add three buttons to the new toolbar.
    ' All three buttons will have the same macro attached.
    Dim newButton1 As AcadToolbarItem
    Dim newButton2 As AcadToolbarItem
    Dim newButton3 As AcadToolbarItem
    Dim openMacro As String
    
    ' Assign the macro string the VB equivalent of "ESC ESC _open "
    openMacro = Chr(3) & Chr(3) & Chr(95) & "open" & Chr(32)
    
    Set newButton1 = newToolBar.AddToolbarButton("", "NewButton1", "Open a file.", openMacro)
    Set newButton2 = newToolBar.AddToolbarButton("", "NewButton2", "Open a file.", openMacro)
    Set newButton3 = newToolBar.AddToolbarButton("", "NewButton3", "Open a file.", openMacro)
    
    ' Display the toolbar
    newToolBar.Visible = True
    newToolBar.Float 200, 200, 1
    
    MsgBox "The toolbar has " & newToolBar.FloatingRows & " row."
    
    newToolBar.FloatingRows = 2
    MsgBox "The toolbar has " & newToolBar.FloatingRows & " rows."
    
    newToolBar.FloatingRows = 3
    MsgBox "The toolbar has " & newToolBar.FloatingRows & " rows."
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_FloatingRows()
    ;; This example creates a new toolbar called "TestToolbar" and inserts three
    ;; buttons into it. The toolbar is then displayed as a floating
    ;; toolbar with 1 and then 3 rows.
    ;; To remove the toolbar after execution of this macro, use the Customize Menu
    ;; option from the Tools menu.
    (setq acadObj (vlax-get-acad-object))
    (setq currMenuGroup (vla-Item (vla-get-MenuGroups acadObj) 0))
  
    ;; Create the new toolbar
    (setq newToolBar (vla-Add (vla-get-Toolbars currMenuGroup) "TestToolbar"))
    
    ;; Add three buttons to the new toolbar.
    ;; All three buttons will have the same macro attached.
    (setq openMacro (strcat (Chr 3) (Chr 3) (Chr 95) "open" (Chr 32)))
    
    (setq newButton1 (vla-AddToolbarButton newToolBar "" "NewButton1" "Open a file." openMacro))
    (setq newButton2 (vla-AddToolbarButton newToolBar "" "NewButton2" "Open a file." openMacro))
    (setq newButton3 (vla-AddToolbarButton newToolBar "" "NewButton3" "Open a file." openMacro))    
    
    ;; Display the toolbar
    (vla-put-Visible newToolBar :vlax-true)
    (vla-Float newToolBar 200 200 1)
    
    (alert (strcat "The toolbar has " (itoa (vla-get-FloatingRows newToolBar)) " row."))
    
    (vla-put-FloatingRows newToolBar 2)
    (alert (strcat "The toolbar has " (itoa (vla-get-FloatingRows newToolBar)) " rows."))
    
    (vla-put-FloatingRows newToolBar 3)
    (alert (strcat "The toolbar has " (itoa (vla-get-FloatingRows newToolBar)) " rows."))
)