Toolbar Object (ActiveX)

An AutoCAD toolbar.

Supported Platforms: Windows only

Class Information

Class Name

AcadToolbar

Object Inheritance
Object
   AcadToolbar
Create Using

VBA

Toolbars.Add
Access Via

VBA

Toolbars.Item

Members

These members are part of this object:

Remarks

Toolbars provide access to frequently used or custom commands, settings, macros, and modes. You can add tools to the AutoCAD default toolbars or create your own toolbars. You can also remove toolbar items or entire toolbars, and reposition toolbars.

To create a new toolbar, use the Add method. The Add method will create an empty toolbar to which you can add toolbar buttons. To add a toolbar button to a toolbar, use the AddToolbarButton method. You can add separators to your toolbar using the AddSeparator method. Both the AddToolbarbutton and AddSeparator methods return a ToolbarItem object representing an individual button on the toolbar. Use the ToolbarItem object to add functionality to the toolbar button, or to create flyout toolbar buttons.

You can change the position of toolbars by docking them along the top, bottom, or sides of the AutoCAD screen, or you can float toolbars anywhere on the screen. To dock a toolbar, use the Dock method. To float a toolbar, use the Float method. To check the current positioning of a toolbar, use the DockStatus property. If you do not want the toolbar to be visible at all, use the Visible property to hide it.