Gets the parent of the object.
Supported platforms: Windows only
VBA:
object.Parent
Type: MenuBar, MenuGroup, MenuGroups, PopupMenu, PopupMenuItem, PopupMenus, Toolbar, ToolbarItem, Toolbars
The objects this property applies to.
Read-only: Yes / No
Type: Object
The user-specified variable must be declared as an appropriate object type. The valid object types are: Application, MenuBar, MenuGroup, MenuGroups, PopupMenu, PopupMenus, Toolbar, Toolbars
No additional remarks.
VBA:
Sub Example_Parent() ' This example creates a new toolbar and then finds the parent toolbar. ' To remove the toolbar after execution of this macro, use the Customize Menu ' option from the Tools menu. Dim currMenuGroup As acadMenuGroup Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0) ' Create the new toolbar Dim newToolBar As AcadToolbar Set newToolBar = currMenuGroup.Toolbars.Add("MyTools") ' Add a button to the new toolbar. ' All three buttons will have the same macro attached. Dim newButton1 As AcadToolbarItem Dim openMacro As String ' Assign the macro string the VB equivalent of "ESC ESC _open " openMacro = Chr(3) & Chr(3) & Chr(95) & "open" & Chr(32) Set newButton1 = newToolBar.AddToolbarButton("", "OpenFile", "Open a file.", openMacro) ' Display the toolbar newToolBar.Visible = True ' Find the parent toolbar for the toolbar button MsgBox "The " & newButton1.name & " button is on the " & newButton1.Parent.name & " toolbar." End Sub
Visual LISP:
(vl-load-com) (defun c:Example_Parent() ;; This example creates a new toolbar and then finds the parent toolbar. ;; To remove the toolbar after execution of this macro, use the Customize Menu ;; option from the Tools menu. (setq acadObj (vlax-get-acad-object)) (setq currMenuGroup (vla-Item (vla-get-MenuGroups acadObj) 0)) ;; Create the new toolbar (setq newToolBar (vla-Add (vla-get-Toolbars currMenuGroup) "MyTools")) ;; Add a button to the new toolbar. ;; All three buttons will have the same macro attached. ;; Assign the macro string the VB equivalent of "ESC ESC _open " (setq openMacro (strcat (Chr 3) (Chr 3) (Chr 95) "open" (Chr 32))) (setq newButton1 (vla-AddToolbarButton newToolBar "" "OpenFile" "Open a file." openMacro)) ;; Display the toolbar (vla-put-Visible newToolBar :vlax-true) ;; Find the parent toolbar for the toolbar button (alert (strcat "The " (vla-get-Name newButton1) " button is on the " (vla-get-Name (vla-get-Parent newButton1)) " toolbar.")) )