TextStyles Collection (ActiveX)

The collection of all text styles in the drawing.

Supported Platforms: Windows only

Class Information

Class Name

AcadTextStyles

Object Inheritance
Object
   AcadObject
      AcadTextStyles
Create Using

VBA

Not applicable
Access Via

VBA

Document.TextStyles

Members

These members are part of this object:

Remarks

To add a new member to the collection, use the Add method. To select a specific text style, use the Item method. To delete a specific text style, use the Delete method found on the TextStyle object.

Although the TextStyles collection inherits a Delete method, you cannot actually delete the collection. Attempting to delete the TextStyles collection will result in an error. The Delete method has been removed from the documentation for this collection.

There is no limit to the number of text styles that you can create in your drawing. However, there can be only one instance of the TextStyles collection. The TextStyles Collection is predefined for each drawing. You can make multiple references to it by using the TextStyles property. Once done with an object, the reference is automatically released.