OwnerID Property (ActiveX)

Gets the object ID of the owner (parent) object.

Supported platforms: Windows only

Signature

VBA:

object.OwnerID 
object

Type: All drawing objects, AttributeReference, Block, Blocks, Dictionary, Dictionaries, Dimension, DimStyle, DimStyles, Group, Groups, Layer, Layers, Layout, Layouts, Linetype, Linetypes, Material, Materials, MLeaderStyle, ModelSpace, PaperSpace, PlotConfiguration, PlotConfigurations, RegisteredApplication, RegisteredApplications, SectionManager, SectionSettings, SortentsTable, TableStyle, TextStyle, TextStyles, UCS, UCSs, View, Views, Viewport, Viewports, XRecord

The objects this property applies to.

Property Value

Read-only: Yes

Type: Long_PTR

The object ID of an object's owner.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_OwnerID()
    ' This example creates an MText object in model space
    ' and then finds the OwnerID for the object.
    
    Dim MTextObj As AcadMText
    Dim corner(0 To 2) As Double
    Dim width As Double
    Dim text As String
    corner(0) = 0#: corner(1) = 10#: corner(2) = 0#
    width = 10
    text = "This is the text string for the MText object"

    ' Creates the MText object
    Set MTextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)
    ZoomAll
    
    MsgBox "The OwnerID for the MText object is: " & MTextObj.OwnerID
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_OwnerID()
    ;; This example creates an MText object in model space
    ;; and then finds the OwnerID for the object.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    (setq corner (vlax-3d-point 0 10 0)
          width 10
          text "This is the text string for the MText object")

    ;; Creates the MText object
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq MTextObj (vla-AddMText modelSpace corner width text))
    (vla-ZoomAll acadObj)
    
    (alert (strcat "The OwnerID for the MText object is: " (itoa (vla-get-OwnerID MTextObj))))
)