Arc Object (ActiveX)

A circular arc.

Supported Platforms: Windows only

Class Information

Class Name

AcadArc

Object Inheritance
Object
   AcadObject
      AcadEntity
         AcadArc
Create Using

VBA

ModelSpace.AddArc
PaperSpace.AddArc
Block.AddArc 
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Remarks

An arc is always drawn counterclockwise from the start point to the endpoint. The StartPoint and EndPoint properties of an arc are calculated through the StartAngle, EndAngle, and Radius properties.



To create an arc, use the AddArc method.