UCS Object (ActiveX)

A user-defined coordinate system that determines the orientation of the X, Y, and Z axes in 3D space.

Supported Platforms: Windows only

Class Information

Class Name

AcadUCS

Object Inheritance
Object
   AcadObject
      AcadUCS
Create Using

VBA

UserCoordinateSystems.Add
Access Via

VBA

UserCoordinateSystems.Item
Document.ActiveUCS

Members

These members are part of this object:

Remarks

You define a UCS to change the location of the (0, 0, 0) origin point and the orientation of the XY plane and the Z axis. You can locate and orient a UCS anywhere in 3D space, and you can define as many UCSs as you require.

All coordinates in ActiveX Automation are entered in the world coordinate system (WCS). Use the GetUCSMatrix method to return the transformation matrix of a given UCS. Use this transformation matrix to find the equivalent WCS coordinates.

Use the UCSIconOn property to turn the UCS icon on or off for a given viewport.

To make a UCS active, use the ActiveUCS property on the Document object. If changes are made to the active UCS, the new UCS object must be reset as the active UCS for the changes to appear. To reset the active UCS, simply call the ActiveUCS property again with the updated UCS object.

To add a new UCS to the drawing, use the Add method off the UCSs Collection.