Specifies the top edge of a toolbar.
Supported platforms: Windows only
Read-only: No
Type: Integer
The top edge of the toolbar.
No additional remarks.
VBA:
Sub Example_Top() ' This example creates a new toolbar called and inserts a ' button into it. The toolbar is then displayed and the top ' position is returned. ' To remove the toolbar after execution of this macro, use the Customize Menu ' option from the Tools menu. Dim currMenuGroup As acadMenuGroup Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0) ' Create the new toolbar Dim newToolBar As AcadToolbar Set newToolBar = currMenuGroup.Toolbars.Add("TestToolbar") ' Add a button to the new toolbar. Dim newButton1 As AcadToolbarItem Dim openMacro As String ' Assign the macro string the VB equivalent of "ESC ESC _open " openMacro = Chr(3) & Chr(3) & Chr(95) & "open" & Chr(32) Set newButton1 = newToolBar.AddToolbarButton("", "NewButton1", "Open a file.", openMacro) ' Display the toolbar newToolBar.Visible = True 'Find the top position Dim currTop As Integer currTop = newToolBar.Top MsgBox "The current value of Top is " & newToolBar.Top, , "Top Example" ' Change the value of Top newToolBar.Top = currTop + 100 MsgBox "The new value of Top is " & newToolBar.Top, , "Top Example" ' Reset the value of Top newToolBar.Top = currTop MsgBox "The value of Top has been reset to " & newToolBar.Top, , "Top Example" End Sub
Visual LISP:
(vl-load-com) (defun c:Example_Top() ;; This example creates a new toolbar called and inserts a ;; button into it. The toolbar is then displayed and the top ;; position is returned. ;; To remove the toolbar after execution of this macro, use the Customize Menu ;; option from the Tools menu. (setq acadObj (vlax-get-acad-object)) (setq currMenuGroup (vla-Item (vla-get-MenuGroups acadObj) 0)) ;; Create the new toolbar (setq newToolBar (vla-Add (vla-get-Toolbars currMenuGroup) "TestToolbar")) ;; Add a button to the new toolbar. ;; Assign the macro string the VB equivalent of "ESC ESC _open " (setq openMacro (strcat (Chr 3) (Chr 3) (Chr 95) "open" (Chr 32))) (setq newButton1 (vla-AddToolbarButton newToolBar "" "NewButton1" "Open a file." openMacro)) ;; Display the toolbar (vla-put-Visible newToolBar :vlax-true) ;; Find the top position (setq currTop (vla-get-Top newToolBar)) (alert (strcat "The current value of Top is " (itoa currTop))) ;; Change the value of Top (vla-put-Top newToolBar (+ currTop 100)) (alert (strcat "The new value of Top is " (itoa (vla-get-Top newToolBar)))) ;; Reset the value of Top (vla-put-Top newToolBar currTop) (alert (strcat "The value of Top has been reset to " (itoa (vla-get-Top newToolBar)))) )