EndSave Event (ActiveX)

Triggered when AutoCAD has finished saving the drawing.

Supported platforms: Windows only

Signature

VBA:

object.EndSave(Filename)
object

Type: Application

An object expression that evaluates to a valid container object. In this case, the only valid container is the application.

Filename

Type: String

The name of the file that was saved.

Remarks

The EndSave event follows the BeginSave event after AutoCAD completes the saving of the drawing.

No events will be fired while a modal dialog is being displayed.

Examples

VBA:

Private Sub AcadDocument_EndSave(ByVal FileName As String)
    ' This example intercepts a drawing EndSave event.
    '
    ' This event is triggered when a drawing finishes a save request.
    '
    ' To trigger this example event: Save an open drawing and wait for the save to complete

    ' Use the "FileName" variable to determine where the drawing file was saved
    MsgBox "A drawing has just been saved to: " & FileName
End Sub

Visual LISP:

Not available