BeginSave Event (ActiveX)

Triggered immediately after AutoCAD receives a request to save the drawing.

Supported platforms: Windows only

Signature

VBA:

object.BeginSave(Filename)
object

Type: Application

An object expression that evaluates to a valid container object. In this case, the only valid container is the application.

Filename

Type: String

The name of the file being saved.

Remarks

The BeginSave event is triggered as soon as AutoCAD receives a request to save along with the name of the file to save. This request can come either interactively by a user through the interface or programmatically.

The BeginSave event is followed by the EndSave event after AutoCAD completes the saving of the drawing.

No events will be fired while a modal dialog is being displayed.

Examples

VBA:

Private Sub AcadDocument_BeginSave(ByVal FileName As String)
    ' This example intercepts a drawing BeginSave event.
    '
    ' This event is triggered when a drawing receives a request to be saved.
    '
    ' To trigger this example event: Save an open drawing

    ' Use the "FileName" variable to determine where the drawing file is being saved
    MsgBox "A drawing is about to be saved to: " & FileName
End Sub

Visual LISP:

Not available