AddDimRotated Method (ActiveX)

Creates a rotated linear dimension.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.AddDimRotated(XLine1Point, XLine2Point, DimLineLocation, RotationAngle)
object

Type: Block, ModelSpace, PaperSpace

The object this method applies to.

XLine1Point

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the first end of the linear dimension to be measured. This is where the first extension line will be attached.

XLine2Point

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the second end of the linear dimension to be measured. This is where the second extension line will be attached.

DimLineLocation

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying a point on the dimension line. This will define the placement of the dimension line and the dimension text.

RotationAngle

Access: Input-only

Type: Double

The angle, in radians, of rotation displaying the linear dimension.

Return Value (RetVal)

Type: DimRotated

The newly created rotated linear dimension object.

Remarks

A linear dimension created at 45 degrees

Examples

VBA:

Sub Example_AddDimRotated()
    ' This example creates a rotated dimension in model space.
        
    Dim dimObj As AcadDimRotated
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    Dim rotAngle As Double
    
    ' Define the dimension
    point1(0) = 0#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 5#: point2(1) = 5#: point2(2) = 0#
    location(0) = 0#: location(1) = 0#: location(2) = 0#
    rotAngle = 120
    rotAngle = rotAngle * 3.141592 / 180#       ' covert to Radians
    
    ' Create the rotated dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimRotated(point1, point2, location, rotAngle)
    ZoomAll
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AddDimRotated()
    ;; This example creates a rotated dimension in model space.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
        
    ;; Define the dimension
    (setq point1 (vlax-3d-point 0 5 0)
          point2 (vlax-3d-point 5 5 0)
          location (vlax-3d-point 0 0 0)
          rotAngle (/ (* 120 3.141592) 180))
    
    ;; Create the rotated dimension in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimRotated modelSpace point1 point2 location rotAngle))
    (vla-ZoomAll acadObj)
)