DimRotated Object (ActiveX)

A dimension that measures the distance between two points and is displayed at a given rotation.

Supported Platforms: Windows only

Class Information

Class Name

AcadDimRotated

Object Inheritance
Object
   AcadObject
      AcadEntity
         AcadDimension
            AcadDimRotated
Create Using

VBA

ModelSpace.AddDimRotated
PaperSpace.AddDimRotated
Block.AddDimRotated
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Methods

Properties

Events

ArrayPolar

ArrayRectangular

Copy

Delete

GetBoundingBox

GetExtensionDictionary

GetXData

Highlight

IntersectWith

Mirror

Mirror3D

Move

Rotate

Rotate3D

ScaleEntity

SetXData

TransformBy

Update

AltRoundDistance

AltSubUnitsFactor

AltSubUnitsSuffix

AltSuppressLeadingZeros

AltSuppressTrailingZeros

AltSuppressZeroFeet

AltSuppressZeroInches

AltTextPrefix

AltTextSuffix

AltTolerancePrecision

AltToleranceSuppressLeadingZeros

AltToleranceSuppressTrailingZeros

AltToleranceSuppressZeroFeet

AltToleranceSuppressZeroInches

AltUnits

AltUnitsFormat

AltUnitsPrecision

AltUnitsScale

Application

Arrowhead1Block

Arrowhead1Type

Arrowhead2Block

Arrowhead2Type

ArrowheadSize

DecimalSeparator

DimConstrDesc

DimConstrExpression

DimConstrForm

DimConstrName

DimConstrReference

DimConstrValue

DimensionLineColor

DimensionLineExtend

DimensionLinetype

DimensionLineWeight

DimLine1Suppress

DimLine2Suppress

DimLineInside

DimTxtDirection

Document

EntityTransparency

ExtensionLineColor

ExtensionLineExtend

ExtensionLineOffset

ExtensionLineWeight

ExtLine1Linetype

ExtLine1Suppress

ExtLine2Linetype

ExtLine2Suppress

ExtLineFixedLen

ExtLineFixedLenSuppress

Fit

ForceLineInside

FractionFormat

Handle

HasExtensionDictionary

HorizontalTextPosition

Hyperlinks

Layer

LinearScaleFactor

Linetype

LinetypeScale

Lineweight

Material

Measurement

Normal

ObjectID

ObjectName

OwnerID

PlotStyleName

PrimaryUnitsPrecision

Rotation

RoundDistance

ScaleFactor

StyleName

SubUnitsFactor

SubUnitsSuffix

SuppressLeadingZeros

SuppressTrailingZeros

SuppressZeroFeet

SuppressZeroInches

TextColor

TextFill

TextFillColor

TextGap

TextHeight

TextInside

TextInsideAlign

TextMovement

TextOutsideAlign

TextOverride

TextPosition

TextPrefix

TextRotation

TextStyle

TextSuffix

ToleranceDisplay

ToleranceHeightScale

ToleranceJustification

ToleranceLowerLimit

TolerancePrecision

ToleranceSuppressLeadingZeros

ToleranceSuppressTrailingZeros

ToleranceSuppressZeroFeet

ToleranceSuppressZeroInches

ToleranceUpperLimit

TrueColor

UnitsFormat

VerticalTextPosition

Visible

Modified

Remarks



A linear dimension created at 45 degrees

To change the extension lines of a rotated dimension, change the Rotation and/or TextPosition properties. The extension lines will be recalculated to fit the new requirements.

To create a rotated dimension, use the AddDimRotated method.