AltRoundDistance Property (ActiveX)

Specifies the rounding of alternate units.

Supported platforms: Windows only

Signature

VBA:

object.AltRoundDistance
object

Type: DimAligned, DimArcLength, DimDiametric, DimOrdinate, DimRadial, DimRadialLarge, DimRotated

The objects this property applies to.

Property Value

Read-only: No

Type: Double

A positive real number representing the value to round distances to. The initial value is 0.00.

Remarks

If the AltUnits property is turned on, this property defines the number to round distances to.

Note: This property overrides the value of the DIMALTRND system variable for the given dimension.

Examples

VBA:

Sub Example_AltRoundDistance()
   ' This example creates an aligned dimension in model space and
   ' uses AltRoundDistance to set the alternate unit display
   ' of the dimension to rounded values

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    
    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 10.123: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    
    ' Enable alternate unit display
    dimObj.AltUnits = True
    
    ThisDrawing.Application.ZoomAll
    
    MsgBox "Press any key to round the alternate dimension unit display to .5"
    
    ' Round the distance of the alternate dimension to 0.50 of a unit
    dimObj.AltRoundDistance = 0.5
    ThisDrawing.Regen acAllViewports
    
    MsgBox "Alternate dimension units have been rounded to: " & dimObj.AltRoundDistance
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AltRoundDistance()
    ;; This example creates an aligned dimension in model space and
    ;; uses AltRoundDistance to set the alternate unit display
    ;; of the dimension to rounded values
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 5 0)
          point2 (vlax-3d-point 10.123 5 0)
          location (vlax-3d-point 5 7 0))

    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    
    ;; Enable alternate unit display
    (vla-put-AltUnits dimObj :vlax-true)
    
    (vla-ZoomAll acadObj)
    
    (alert "Round the alternate dimension unit display to .5")
    
    ;; Round the distance of the alternate dimension to 0.50 of a unit
    (vla-put-AltRoundDistance dimObj 0.5)
    (vla-Regen doc acAllViewports)
    
    (alert (strcat "Alternate dimension units have been rounded to: " (rtos (vla-get-AltRoundDistance dimObj) 2 4)))
)