DimRadial Object (ActiveX)

A dimension measuring the radius of a circle or arc.

Supported Platforms: Windows only

Class Information

Class Name

AcadDimRadial

Object Inheritance
Object
   AcadObject
      AcadEntity
         AcadDimension
            AcadDimRadial
Create Using

VBA

ModelSpace.AddDimRadial
PaperSpace.AddDimRadial
Block.AddDimRadial
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Methods

Properties

Events

ArrayPolar

ArrayRectangular

Copy

Delete

GetBoundingBox

GetExtensionDictionary

GetXData

Highlight

IntersectWith

Mirror

Mirror3D

Move

Rotate

Rotate3D

ScaleEntity

SetXData

TransformBy

Update

AltRoundDistance

AltSuppressLeadingZeros

AltSuppressTrailingZeros

AltSuppressZeroFeet

AltSuppressZeroInches

AltTextPrefix

AltTextSuffix

AltTolerancePrecision

AltToleranceSuppressLeadingZeros

AltToleranceSuppressTrailingZeros

AltToleranceSuppressZeroFeet

AltToleranceSuppressZeroInches

AltUnits

AltUnitsFormat

AltUnitsPrecision

AltUnitsScale

Application

ArrowheadBlock

ArrowheadSize

ArrowheadType

CenterMarkSize

CenterType

DecimalSeparator

DimConstrDesc

DimConstrExpression

DimConstrForm

DimConstrName

DimConstrReference

DimConstrValue

DimensionLineColor

DimensionLinetype

DimensionLineWeight

DimLineSuppress

DimTxtDirection

Document

EntityTransparency

Fit

ForceLineInside

FractionFormat

Handle

HasExtensionDictionary

Hyperlinks

Layer

LeaderLength

LinearScaleFactor

Linetype

LinetypeScale

Lineweight

Material

Measurement

Normal

ObjectID

ObjectName

OwnerID

PlotStyleName

PrimaryUnitsPrecision

Rotation

RoundDistance

ScaleFactor

StyleName

SuppressLeadingZeros

SuppressTrailingZeros

SuppressZeroFeet

SuppressZeroInches

TextColor

TextFill

TextFillColor

TextGap

TextHeight

TextInside

TextInsideAlign

TextMovement

TextOutsideAlign

TextOverride

TextPosition

TextPrefix

TextRotation

TextStyle

TextSuffix

ToleranceDisplay

ToleranceHeightScale

ToleranceJustification

ToleranceLowerLimit

TolerancePrecision

ToleranceSuppressLeadingZeros

ToleranceSuppressTrailingZeros

ToleranceSuppressZeroFeet

ToleranceSuppressZeroInches

ToleranceUpperLimit

TrueColor

UnitsFormat

VerticalTextPosition

Visible

Modified

Remarks

The position of the text (TextPosition property) determines the location of the dimension line.



Examples of radial dimensions

To create a radial dimension, use the AddDimRadial method.