Shape Object (ActiveX)

An object comprising lines, arcs, and circles defined in an SHX file.

Supported Platforms: Windows only

Class Information

Class Name

AcadShape

Object Inheritance
Object
   AcadObject
      AcadEntity
         AcadShape
Create Using

VBA

ModelSpace.AddShape
PaperSpace.AddShape
Block.AddShape
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Remarks

Before inserting a shape, you must load the file containing the desired shape. To load a shape file, use the LoadShapeFile method. To insert the shape into the drawing, use the AddShape method.