ExtensionLineExtend Property (ActiveX)

Specifies the distance the extension line extends beyond the dimension line.

Supported platforms: Windows only

Signature

VBA:

object.ExtensionLineExtend
object

Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimRotated

The objects this property applies to.

Property Value

Read-only: No

Type: Double

A positive real number specifying the distance to extend the extension line beyond the dimension line.

Remarks

The initial value for this property is 0.1800.

Note: This property overrides the value of the DIMEXE system variable for the given dimension.

Examples

VBA:

Sub Example_ExtensionLineExtend()
    ' This example creates a Dim3PointAngular object in model space
    ' and changes the length of the extension line to extend 1.5 units past
    ' the dimension using the ExtensionLineExtend property
    
    Dim DimPointAngularObj As AcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    
    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Application.ZoomAll

    ' Read and display current extension line extend length
    MsgBox "The extension line currently extends " & DimPointAngularObj.ExtensionLineExtend & " units past the dimension"

    ' Change the extension line extend length to extend 1.5
    ' units past the dimension
    DimPointAngularObj.ExtensionLineExtend = 1.5
    ThisDrawing.Regen acAllViewports
    
    ' Read and display current extension line extend length
    MsgBox "The extension line now extends " & DimPointAngularObj.ExtensionLineExtend & " units past the dimension"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ExtensionLineExtend()
    ;; This example creates a Dim3PointAngular object in model space
    ;; and changes the length of the extension line to extend 1.5 units past
    ;; the dimension using the ExtensionLineExtend property
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the new Dim3PointAngular object
    (setq AngleVertex (vlax-3d-point 0 0 0)
          FirstPoint (vlax-3d-point 2 2 0)
          SecondPoint (vlax-3d-point 1 4 0)
          TextPoint (vlax-3d-point 6 6 0))

    ;; Create the new Dim3PointAngular object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq DimPointAngularObj (vla-AddDim3PointAngular modelSpace AngleVertex FirstPoint SecondPoint TextPoint))
    (vla-ZoomAll acadObj)

    ;; Read and display current extension line extend length
    (alert (strcat "The extension line currently extends " (rtos (vla-get-ExtensionLineExtend DimPointAngularObj) 2) " units past the dimension"))

    ;; Change the extension line extend length to extend 1.5
    ;; units past the dimension
    (vla-put-ExtensionLineExtend DimPointAngularObj 1.5)
    (vla-Regen doc acAllViewports)
    
    ;; Read and display current extension line extend length
    (alert (strcat "The extension line now extends " (rtos (vla-get-ExtensionLineExtend DimPointAngularObj) 2) " units past the dimension"))
)