DimAngular Object (ActiveX)

A dimension measuring the angular distance between two lines or between the angle of a circular arc.

Supported Platforms: Windows only

Class Information

Class Name

AcadDimAngular

Object Inheritance
Object
   AcadObject
      AcadEntity
         AcadDimension
            AcadDimAngular
Create Using

VBA

ModelSpace.AddDimAngular
PaperSpace.AddDimAngular
Block.AddDimAngular
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Methods

Properties

Events

ArrayPolar

ArrayRectangular

Copy

Delete

GetBoundingBox

GetExtensionDictionary

GetXData

Highlight

IntersectWith

Mirror

Mirror3D

Move

Rotate

Rotate3D

ScaleEntity

SetXData

TransformBy

Update

AngleFormat

Application

Arrowhead1Block

Arrowhead1Type

Arrowhead2Block

Arrowhead2Type

ArrowheadSize

DecimalSeparator

DimConstrDesc

DimConstrExpression

DimConstrForm

DimConstrName

DimConstrReference

DimConstrValue

DimensionLineColor

DimensionLinetype

DimensionLineWeight

DimLine1Suppress

DimLine2Suppress

DimLineInside

DimTxtDirection

Document

EntityTransparency

ExtensionLineColor

ExtensionLineExtend

ExtensionLineOffset

ExtensionLineWeight

ExtLine1EndPoint

ExtLine1Linetype

ExtLine1StartPoint

ExtLine1Suppress

ExtLine2EndPoint

ExtLine2Linetype

ExtLine2StartPoint

ExtLine2Suppress

ExtLineFixedLen

ExtLineFixedLenSuppress

Fit

ForceLineInside

Handle

HasExtensionDictionary

HorizontalTextPosition

Hyperlinks

Layer

Linetype

LinetypeScale

Lineweight

Material

Measurement

Normal

ObjectID

ObjectName

OwnerID

PlotStyleName

Rotation

ScaleFactor

StyleName

SuppressLeadingZeros

SuppressTrailingZeros

TextColor

TextFill

TextFillColor

TextGap

TextHeight

TextInside

TextInsideAlign

TextMovement

TextOutsideAlign

TextOverride

TextPosition

TextPrecision

TextPrefix

TextRotation

TextStyle

TextSuffix

ToleranceDisplay

ToleranceHeightScale

ToleranceJustification

ToleranceLowerLimit

TolerancePrecision

ToleranceSuppressLeadingZeros

ToleranceSuppressTrailingZeros

ToleranceUpperLimit

TrueColor

VerticalTextPosition

Visible

Modified

Remarks

If you need extension lines, they will be added automatically. The endpoints provided will be used as origin points for the extension lines.



An angular dimension measuring the angle of a circular arc

To create an angular dimension, use the AddDimAngular method.