EnableMergeAll Method (ActiveX)

Controls cell merging.

Supported platforms: Windows only

Signature

VBA:

object.EnableMergeAll nRow, nCol, bEnable
object

Type: Table, TableStyle

The objects this method applies to.

nRow

Access: Input-only

Type: Integer

The value of the row.

nCol

Access: Input-only

Type: Integer

The value of the column.

bEnable

Access: Input-only

Type: Boolean

The flag for cell merging.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_EnableMergeAll()
    ' This example creates a TableStyle object and sets values for
    ' the style cell merging.
    
    Dim dictionaries As AcadDictionaries
    Set dictionaries = ThisDrawing.Database.dictionaries
  
    Dim dictObj As AcadDictionary
    Set dictObj = dictionaries.Item("acad_tablestyle")
  
    ' Create the custom TableStyle object in the dictionary
    Dim keyName As String
    Dim className As String
    Dim customObj As IAcadTableStyle
    keyName = "NewStyle"
    className = "AcDbTableStyle"
    Set customObj = dictObj.AddObject(keyName, className)
      
    customObj.Name = "NewStyle"
    customObj.Description = "New Style for My Tables"
  
    customObj.CreateCellStyle "NewTestStyle2"
    customObj.EnableMergeAll "NewTestStyle2", False
      
    If customObj.GetIsMergeAllEnabled("NewTestStyle2") = False Then
        MsgBox "Merge all is not enabled!"
    End If
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_EnableMergeAll()
    ;; This example creates a TableStyle object and sets values for
    ;; the style cell merging.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (setq dictionaries (vla-get-Dictionaries doc))
    (setq dictObj (vla-Item dictionaries "acad_tablestyle"))
  
    ;; Create the custom TableStyle object in the dictionary
    (setq keyName "NewStyle"
          className "AcDbTableStyle")
    (setq customObj (vla-AddObject dictObj keyName className))
      
    (vla-put-Name customObj "NewStyle")
    (vla-put-Description customObj "New Style for My Tables")
  
    (vla-CreateCellStyle customObj "NewTestStyle2")
    (vla-EnableMergeAll customObj "NewTestStyle2" :vlax-false)
      
    (if (= (vla-GetIsMergeAllEnabled customObj "NewTestStyle2") :vlax-false)
        (alert "Merge all is not enabled!")
    )
)