AutoCAD table object.
Supported Platforms: Windows only
AcadTable
Object AcadObject AcadEntity AcadTable
VBA
ModelSpace.AddTable PaperSpace.AddTable Block.AddTable
VBA
ModelSpace.Item PaperSpace.Item Block.Item SelectionSet.Item Group.Item
These members are part of this object:
Methods |
Properties |
Events |
---|---|---|
A table contains data in rows and columns. You can use the Table object to add and modify tables in a drawing.
To add a table to a drawing, use the AddTable method. After you add a table, you can modify the number of columns, the number of rows, and other settings.
All methods that change the Table object do the following:
Recomputing large tables consumes a lot of time and memory because the Table object is reconstructed from scratch. If you are making multiple calls to update a table, you can improve performance by setting RegenerateTableSuppressed before and after making the modifications.