3DFace Object (ActiveX)

A 3D triangle or quadrilateral plane section.

Supported Platforms: Windows only

Class Information

Class Name

Acad3DFace

Object Inheritance
Object
   AcadObject
      AcadEntity
         Acad3DFace
Create Using

VBA

ModelSpace.Add3DFace
PaperSpace.Add3DFace
Block.Add3DFace 
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item 

Members

These members are part of this object:

Remarks

You can specify different Z coordinates for each corner point of a 3DFace object. This differs from a Solid object, which creates a three- or four-sided surface that is parallel to the current UCS and can be extruded.



Six 3DFaces joined together to make a cube

You control which edges of the face are visible through the SetInvisibleEdge method. This allows accurate modeling of objects with holes.

To create a 3DFace, use the Add3DFace method.