Specifies the suppression of the dimension line for radial dimensions.
Supported platforms: Windows only
VBA:
object.DimLineSuppress
Type: DimRadial, DimRadialLarge
The objects this property applies to.
Read-only: No
Type: Boolean
The initial value for this property is False.
When this property is set to True, the display of the dimension line and arrowhead between the extension line and the text is suppressed.
VBA:
Sub Example_DimLineSuppress() ' This example creates a Radial Dimension in model space and ' uses the DimLineSuppress property to toggle the display ' of the dimension lines Dim dimObj As AcadDimRadial Dim center(0 To 2) As Double Dim chordPoint(0 To 2) As Double Dim leaderLen As Integer ' Define the dimension center(0) = 0: center(1) = 0: center(2) = 0 chordPoint(0) = 5: chordPoint(1) = 5: chordPoint(2) = 0 leaderLen = 5 ' Create the radial dimension in model space Set dimObj = ThisDrawing.ModelSpace.AddDimRadial(center, chordPoint, leaderLen) ThisDrawing.Application.ZoomAll MsgBox "The radial dimension has been created.", vbInformation dimObj.DimLineSuppress = Not (dimObj.DimLineSuppress) ThisDrawing.Application.ZoomAll MsgBox "The radial dimension appearance has been modified.", vbInformation End Sub
Visual LISP:
(vl-load-com) (defun c:Example_DimLineSuppress() ;; This example creates a Radial Dimension in model space and ;; uses the DimLineSuppress property to toggle the display ;; of the dimension lines (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the dimension (setq center (vlax-3d-point 0 0 0) chordPoint (vlax-3d-point 5 5 0) leaderLen 5) ;; Create the radial dimension in model space (setq modelSpace (vla-get-ModelSpace doc)) (setq dimObj (vla-AddDimRadial modelSpace center chordPoint leaderLen)) (vla-ZoomAll acadObj) (alert "The radial dimension has been created.") (vla-put-DimLineSuppress dimObj (if (= (vla-get-DimLineSuppress dimObj) :vlax-true) :vlax-false :vlax-true)) (vla-ZoomAll acadObj) (alert "The radial dimension appearance has been modified.") )