Sets the breaking height for the initial table part and any other table parts that do not have manual heights set.
Supported platforms: Windows only
Read-only: No
Type: Double
Value for the break height.
No additional remarks.
VBA:
Sub Example_BreakHeight() ' This example creates a table object and then breaks it into ' two tables. ' Create a new table objetc in model space Dim pt(2) As Double Dim modelSpace As AcadModelSpace Set modelSpace = ThisDrawing.modelSpace Dim table As AcadTable Set table = modelSpace.AddTable(pt, 5, 5, 10, 30) table.EnableBreak = True table.BreakSpacing = 3.5 table.TableBreakHeight = 35# table.AllowManualHeights = True table.SetBreakHeight 0, 20# table.SetBreakHeight 1, 35# ZoomExtents End Sub
Visual LISP:
(vl-load-com) (defun c:Example_BreakHeight() ;; This example creates a table object and then breaks it into ;; two tables. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Create a new table objetc in model space (setq pt (vlax-3d-point 0 0 0)) (setq modelSpace (vla-get-ModelSpace doc)) (setq table (vla-Addtable modelSpace pt 5 5 10 30)) (vla-put-EnableBreak table :vlax-true) (vla-put-BreakSpacing table 3.5) (vla-put-TableBreakHeight table 35.0) (vla-put-AllowManualHeights table :vlax-true) (vla-SetBreakHeight table 0 20.0) (vla-SetBreakHeight table 1 35.0) (vla-ZoomExtents acadObj) )