ToleranceSuppressZeroFeet Property (ActiveX)

Specifies the suppression of a zero foot measurement in tolerance values.

Supported platforms: Windows only

Signature

VBA:

object.ToleranceSuppressZeroFeet
object

Type: DimAligned, DimArcLength, DimDiametric, DimOrdinate, DimRadial, DimRadialLarge, DimRotated

The objects this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is False.

Note: This property overrides the value for the DIMTZIN system variable for the given dimension.

Examples

VBA:

Sub Example_ToleranceSuppressZeroFeet()
    ' This example creates an aligned dimension in model space and
    ' uses ToleranceSuppressZeroFeet to toggle the display of zeros feet
    ' in the dimension tolerance display

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    
    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 6.01: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 8: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.UnitsFormat = acDimLArchitectural
    
    ' Enable and setup tolerance display
    dimObj.ToleranceDisplay = acTolLimits
    dimObj.ToleranceLowerLimit = -0.0001: dimObj.ToleranceUpperLimit = 0.0001
    
    ZoomAll
    
Toggle:
    Select Case MsgBox("Press OK to toggle the display of zero feet in the dimension tolerance", vbOKCancel)
        Case vbOK
            ' Toggle the display of zero feet for the dimension tolerance value
            dimObj.ToleranceSuppressZeroFeet = Not (dimObj.ToleranceSuppressZeroFeet)
            ThisDrawing.Regen acAllViewports
        
        Case vbCancel
            Exit Sub
    End Select
    
    GoTo Toggle
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ToleranceSuppressZeroFeet()
    ;; This example creates an aligned dimension in model space and
    ;; uses ToleranceSuppressZeroFeet to toggle the display of zeros feet
    ;; in the dimension tolerance display
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 5 0)
          point2 (vlax-3d-point 6.01 5 0)
          location (vlax-3d-point 5 8 0))
    
    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    (vla-put-UnitsFormat dimObj acDimLArchitectural)
    
    ;; Enable and setup tolerance display
    (vla-put-ToleranceDisplay dimObj acTolLimits)
    (vla-put-ToleranceLowerLimit dimObj -0.0001)
    (vla-put-ToleranceUpperLimit dimObj 0.0001)

    (vla-ZoomAll acadObj)

    ;; Toggle the display of zero feet for the dimension tolerance value
    (vla-put-ToleranceSuppressZeroFeet dimObj (if (= (vla-get-ToleranceSuppressZeroFeet dimObj) :vlax-true) :vlax-false :vlax-true))
    (vla-Regen doc acAllViewports)
    (alert "Suppression of zero feet toggled.")

    ;; Toggle the display of zero feet for the dimension tolerance value back to previous state
    (vla-put-ToleranceSuppressZeroFeet dimObj (if (= (vla-get-ToleranceSuppressZeroFeet dimObj) :vlax-true) :vlax-false :vlax-true))
    (vla-Regen doc acAllViewports)
    (alert "Suppression of zero feet toggled back.")
)