AltUnitsFormat Property (ActiveX)

Specifies the units format for alternate units of all dimensions except angular.

Supported platforms: Windows only

Signature

VBA:

object.AltUnitsFormat
object

Type: DimAligned, DimArcLength, DimDiametric, DimOrdinate, DimRadial, DimRadialLarge, DimRotated

The objects this property applies to.

Property Value

Read-only: No

Type: acDimUnits enum

Remarks

The initial value for this property is acDimDecimal.

Note: This property overrides the value of the DIMALTU system variable for the given dimension.

Examples

VBA:

Sub Example_AltUnitsFormat()
    ' This example creates an aligned dimension in model space and
    ' uses AltUnitsFormat to cycle through some common unit formats
    ' for the alternate dimension

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    
    ' Define the dimension
    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 5.12345678: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ThisDrawing.Application.ZoomAll
    
    ' Enable unit display of alternate units
    dimObj.AltUnits = True
      
    dimObj.AltUnitsFormat = acDimScientific     ' Change format to Scientific
    ThisDrawing.Regen acAllViewports
    MsgBox "The alternate dimension units are now set to Scientific"
    
    dimObj.AltUnitsFormat = acDimDecimal        ' Change format to Decimal
    ThisDrawing.Regen acAllViewports
    MsgBox "The alternate dimension units are now set to Decimal"
    
    dimObj.AltUnitsFormat = acDimArchitectural  ' Change format to Architectural
    ThisDrawing.Regen acAllViewports
    MsgBox "The alternate dimension units are now set to Architectural"
    
    dimObj.AltUnitsFormat = acDimWindowsDesktop ' Change format to Windows Desktop
    ThisDrawing.Regen acAllViewports
    MsgBox "The alternate dimension units are now set to Windows Desktop"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AltUnitsFormat()
    ;; This example creates an aligned dimension in model space and
    ;; uses AltUnitsFormat to cycle through some common unit formats
    ;; for the alternate dimension
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))  

    ;; Define the dimension
    (setq point1 (vlax-3d-point 0 5 0)
          point2 (vlax-3d-point 5.12345678 5 0)
          location (vlax-3d-point 5 7 0))

    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    (vla-ZoomAll acadObj)
    
    ;; Enable unit display of alternate units
    (vla-put-AltUnits dimObj :vlax-true)
      
    (vla-put-AltUnitsFormat dimObj acDimScientific)     ;; Change format to Scientific
    (vla-Regen doc acAllViewports)
    (alert "The alternate dimension units are now set to Scientific.")
    
    (vla-put-AltUnitsFormat dimObj acDimDecimal)        ;; Change format to Decimal
    (vla-Regen doc acAllViewports)
    (alert "The alternate dimension units are now set to Decimal.")
    
    (vla-put-AltUnitsFormat dimObj acDimArchitectural)  ;; Change format to Architectural
    (vla-Regen doc acAllViewports)
    (alert "The alternate dimension units are now set to Architectural.")
    
    (vla-put-AltUnitsFormat dimObj acDimWindowsDesktop) ;; Change format to Windows Desktop
    (vla-Regen doc acAllViewports)
    (alert "The alternate dimension units are now set to Windows Desktop.")
)