FractionFormat Property (ActiveX)

Specifies the format of fractional values in dimensions and tolerances.

Supported platforms: Windows only

Signature

VBA:

object.FractionFormat
object

Type: DimAligned, DimArcLength, DimDiametric, DimOrdinate, DimRadial, DimRadialLarge, DimRotated

The objects this property applies to.

Property Value

Read-only: No

Type: acDimFractionType enum

Remarks

This property is used when the UnitsFormat property is set to acDimLArchitectural or acDimLFractional.

Note: This property overrides the value of the DIMFRAC system variable for the given dimension.

Examples

VBA:

Sub Example_FractionFormat()
    ' This example creates an aligned dimension in model space and
    ' uses FractionFormat to cycle through some fractional formats
    ' for the dimension.
    ' * Note the appearance of the "1/2" component of the dimension

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    
    ' Define the dimension
    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 5.5: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ThisDrawing.Application.ZoomAll
    
    ' Switch to a mode that works with the FractionFormat property
    dimObj.UnitsFormat = acDimLArchitectural
      
    ' Cycle through some common fractional formats
    
    dimObj.FractionFormat = acDiagonal      ' Change format to Diagonal
    ThisDrawing.Regen acAllViewports
    MsgBox "The dimension format is now set to diagonal"
    
    dimObj.FractionFormat = acHorizontal    ' Change format to Horizontal
    ThisDrawing.Regen acAllViewports
    MsgBox "The dimension format is now set to horizontal"

    dimObj.FractionFormat = acNotStacked    ' Change format to NotStacked
    ThisDrawing.Regen acAllViewports
    MsgBox "The dimension format is now unstacked"

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_FractionFormat()
   ;; This example creates an aligned dimension in model space and
   ;; uses FractionFormat to cycle through some fractional formats
   ;; for the dimension.
   ;; * Note the appearance of the "1/2" component of the dimension
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Define the dimension
    (setq point1 (vlax-3d-point 0 5 0)
          point2 (vlax-3d-point 5.5 5 0)
          location (vlax-3d-point 5 7 0))
    
    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    (vla-ZoomAll acadObj)
    
    ;; Switch to a mode that works with the FractionFormat property
    (vla-put-UnitsFormat dimObj acDimLArchitectural)
      
    ;; Cycle through some common fractional formats
    (vla-put-FractionFormat dimObj acDiagonal)      ;; Change format to Diagonal
    (vla-Regen doc acAllViewports)
    (alert "The dimension format is now set to diagonal")
    
    (vla-put-FractionFormat dimObj acHorizontal)    ;; Change format to Horizontal
    (vla-Regen doc acAllViewports)
    (alert "The dimension format is now set to horizontal")

    (vla-put-FractionFormat dimObj acNotStacked)    ;; Change format to NotStacked
    (vla-Regen doc acAllViewports)
    (alert "The dimension format is now unstacked")
)