SetDataType Method (ActiveX)

Sets the data type and unit type for the specified row type.

Supported platforms: Windows only

Signature

VBA:

object.SetDataType rowTypes, nDataType, nUnitType
object

Type: Table, TableStyle

The objects this method applies to.

rowTypes

Access: Input-only

Type: AcRowType enum

The row types to change.

  • acDataRow
  • acHeaderRow
  • acTitleRow
  • acUnknownRow
nDataType

Access: Input-only

Type: AcValueDataType enum

The new data type.

  • acBuffer
  • acDate
  • acDouble
  • acGeneral
  • acLong
  • acObjectId
  • acPoint2d
  • acPoint3d
  • acResbuf
  • acString
  • acUnknownDataType
nUnitType

Access: Input-only

Type: AcValueUnitType enum

The new unit type.

  • acUnitAngle
  • acUnitArea
  • acUnitDistance
  • acUnitless
  • acUnitVolume

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Examples

VBA:

Not available

Visual LISP:

Not available