SetDataType2 Method (ActiveX)

Sets the row data type and unit type for the specified row type and content.

Supported platforms: Windows only

Signature

VBA:

object.SetDataType2 nRow, nCol, nContent, dataType, unitType
object

Type: Table, TableStyle

The object this method applies to.

nRow

Access: Input-only

Type: Long

The row number of the cell to set.

nCol

Access: Input-only

Type: Long

The column number of the cell to set.

nContent

Access: Input-only

Type: Long

The content value for the cell.

dataType

Access: Input-only

Type: AcValueDataType enum

The new data type.

  • acBuffer
  • acDate
  • acDouble
  • acGeneral
  • acLong
  • acObjectId
  • acPoint2d
  • acPoint3d
  • acResbuf
  • acString
  • acUnknownDataType
unitType

Access: Input-only

Type: AcValueUnitType enum

The new unit type.

  • acUnitAngle
  • acUnitArea
  • acUnitDistance
  • acUnitless
  • acUnitVolume

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Examples

VBA:

Not available

Visual LISP:

Not available