GetRotation Method (ActiveX)

Gets the rotation value for a cell or cell style.

Supported platforms: Windows only

Signature - Table

VBA:

RetVal = object.GetRotation(nRow, nCol, nContent)
object

Type: Table

The object this method applies to.

nRow

Access: Input-only

Type: Long

The row number of the cell to set.

nCol

Access: Input-only

Type: Long

The column number of the cell to set.

nContent

Access: Input-only

Type: Long

The content value for the cell.

Signature - TableStyle

VBA:

RetVal = object.GetRotation(StringCellStyle)
object

Type: TableStyle

The object this method applies to.

StringCellStyle

Access: Input-only

Type: String

The cell style name.

Return Value (RetVal)

Type: Double

The rotation value for the cell or cell style.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_CellClass()
    ' This example creates a TableStyle object and sets values for
    ' the style classes and formatting.
    
    Dim dictionaries As AcadDictionaries
    Set dictionaries = ThisDrawing.Database.dictionaries
  
    Dim dictObj As AcadDictionary
    Set dictObj = dictionaries.Item("acad_tablestyle")
  
    ' Create the custom TableStyle object in the dictionary
    Dim keyName As String
    Dim className As String
    Dim customObj As IAcadTableStyle
    keyName = "NewStyle"
    className = "AcDbTableStyle"
    Set customObj = dictObj.AddObject(keyName, className)
      
    customObj.Name = "NewStyle"
    customObj.Description = "New Style for My Tables"
  
    customObj.CreateCellStyle ("NewTestStyle")
    Dim cellTestFormat As String
      
    customObj.SetCellClass "NewTestStyle", 4
      
    customObj.SetRotation "NewTestStyle", 8.4
      
    MsgBox "The cell class is " & customObj.GetCellClass("NewTestStyle") & _
           " the cell rotation is " & customObj.GetRotation("NewTestStyle")
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_CellClass()
    ;; This example creates a TableStyle object and sets values for
    ;; the style classes and formatting.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (setq dictionaries (vla-get-Dictionaries doc))
  
    (setq dictObj (vla-Item dictionaries "acad_tablestyle"))
  
    ;; Create the custom TableStyle object in the dictionary
    (setq keyName "NewStyle"
          className "AcDbTableStyle")
    (setq customObj (vla-AddObject dictObj keyName className))
      
    (vla-put-Name customObj "NewStyle")
    (vla-put-Description customObj "New Style for My Tables")
  
    (vla-CreateCellStyle customObj "NewTestStyle")

    (vla-SetCellClass customObj "NewTestStyle" 4)
    (vla-SetRotation customObj "NewTestStyle" 8.4)
      
    (alert (strcat "The cell class is " (itoa (vla-GetCellClass customObj "NewTestStyle"))
                   " and the cell rotation is " (rtos (vla-GetRotation customObj "NewTestStyle") 2) "."
           )
    )
)