The VLX namespace functions listed below apply to separate-namespace VLX applications. These functions allow separate-namespace VLX functions to be accessible from a document namespace, enable the retrieval and updating of variables in the associated document namespace, and provide error-handling routines for separate-namespace VLX functions.
VLX namespace functions |
|
---|---|
Function |
Description |
Imports ADS-DEFUN functions into a separate-namespace VLX |
|
Makes a function loaded in a VLX namespace available to the current document |
|
Imports a function that was previously exported from another separate-namespace VLX |
|
Retrieves the value of a variable from the namespace of the associated document |
|
Sets the value of a variable in the associated document's namespace |
|
Passes control from a VLX error handler to the *error* function of the associated document namespace |
|
Returns a value to the document namespace from which the VLX was invoked |
|
Lists all functions exported by the specified application, or all exported functions if no application is specified |
|
Returns a list of all separate-namespace VLX files associated with the current document |
|
Unloads a VLX that is loaded in its own namespace (a separate-namespace VLX) |
|
Determines whether a VLX is loaded in its own namespace |