vl-exit-with-error (AutoLISP)

Passes control from an error handler to the *error* function of the calling namespace

Supported Platforms: Windows and Mac OS

Signature

(vl-exit-with-error msg)
msg

Type: String

Message displayed to the user.

Return Values

Type: None

None

Remarks

This function is used by applications that run in their own namespace. When vl-exit-with-error executes, it calls the *error* function, the stack is unwound, and control returns to a command prompt.

Examples

The following code illustrates the use of vl-exit-with-error to pass a string to the *error* function of the calling namespace:

(defun *error* (msg)
  ... ; processing in VLX namespace/execution context
(vl-exit-with-error (strcat "My application bombed! " msg)))